Install v2.0.2 issues

Current Version: 2.0.2
Released: 2013-10-27
Forum rules
Before creating a new support thread, please take a look at the board3 Portal FAQ and use the search!
Many questions have already been answered.
Kurt
Topic author
Active Member
Active Member
Posts: 5
Joined: 7. June 2014 19:12

Install v2.0.2 issues

Post by Kurt » 7. June 2014 19:31

Your Portal Version: v2.0.2
Your phpBB Type: Standard phpBB3
MODs installed: No
Your knowledge: Basic Knowledge

What have you done before the problem was there?
I'm moving my b-board (phpbb 3.11 & board v1.3) to a new hosting. There I have a standard setup phpbb 3.12 ready. I imported the DB and converted it to v3.12 with install/database_update.php file that I used from the setup v3.12 package. Board is working so far.

What have you already tryed to solve the problem?
checking portal permissions
trying to look at the error pages in the messages
purge the cache & refresh the styles.


Description and Message
Then I Installed board v2.0.2, following the step by step guide in the package. (funny there I can't copy the modifcations with supplied link? I need to copy manually, I run this file on my local disk)
First error I saw was when running the install/index.php, it says a board table already exists.
Then in ACP I can't access the MOD tab.
It looks like there are still remains of the v1.3 board that are causing issues here?
I working on this all day, are there infact upgrade procedures available?
I did a new install of the phpbb and the board (using my existing DB) but even then I'm getting errors.

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1432
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Install v2.0.2 issues

Post by Kirk » 8. June 2014 08:02

You have to first remove all files with board v1.3.
Then install the new version.
Gruß Udo

Kurt
Topic author
Active Member
Active Member
Posts: 5
Joined: 7. June 2014 19:12

Re: Install v2.0.2 issues

Post by Kurt » 8. June 2014 20:30

Since I'm on a new hosting with a default phpbb install, I think all v1.3 files are 'removed', but maybe the database table are causing problems? How can I solve this. Do I manually need to clean up the database?
Also the install af the new version v2.0.2, do I really need to cope each file manually and also do modifications of the files one by one manually? Or is there a sort of automatic install possible?

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1432
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Install v2.0.2 issues

Post by Kirk » 9. June 2014 10:17

You have to remove the database entries for v1.3. Calls to the install.xml for v1.3 and click Uninstall.
Kurt wrote:Also the install af the new version v2.0.2, do I really need to cope each file manually and also do modifications of the files one by one manually? Or is there a sort of automatic install possible?
With the Automod it's possible.
Gruß Udo

Kurt
Topic author
Active Member
Active Member
Posts: 5
Joined: 7. June 2014 19:12

Re: Install v2.0.2 issues

Post by Kurt » 14. June 2014 22:05

I uploaded again the original v1.0.3 (not 1.3 like a said earlier) install files to the forum, but when viewing the install.xml, all I see are the instructions how to upload and modify files.
There is no expalantion how the database tables are modifoed for this setup of board v1.0.3.
So how can I undo the database changes then so I can insgtall the latest version 2.0.2 without errors?

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1432
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Install v2.0.2 issues

Post by Kirk » 16. June 2014 17:17

Kurt wrote:So how can I undo the database changes then so I can insgtall the latest version 2.0.2 without errors?
Browse to install/index.php and and click on Uninstall.
Gruß Udo

Kurt
Topic author
Active Member
Active Member
Posts: 5
Joined: 7. June 2014 19:12

Re: Install v2.0.2 issues

Post by Kurt » 16. June 2014 23:28

OK I did this step and visited /install/index.php, there I choose uninstall and get a confirmation that the board was uninstalled and also this note;
'Remember to delete the Portal-related files and reverse any Portal-related edits made to phpBB core files.'
In fact so far I don't see any difference on the site, the board is still there and also in phpmyadmin I still have a _portal_config table in my DB.
I do noticed I don't have a MOD tab anymore in ACP.
So it looks I also need to follow the steps in install.xml in 'reverse order' to undo completely the board v1.0.3 setup.
But then I still have the portal table? Do I also need to deleted this table manually? I thought the Uninstall would do this?

That's a lot a manual work, it's a pitty there is no upgrade possible for v1.0.3 to 2.0.2, after all this manual work I will have to re-configure and add the links again in the link section on the 2.0.2 version.

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1432
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Install v2.0.2 issues

Post by Kirk » 17. June 2014 17:47

Kurt wrote:But then I still have the portal table? Do I also need to deleted this table manually?
If you do delete it manually, make a backup before.
Kurt wrote:I thought the Uninstall would do this?
So it should be, unless you have these manually in the DB.
Gruß Udo

Kurt
Topic author
Active Member
Active Member
Posts: 5
Joined: 7. June 2014 19:12

Re: Install v2.0.2 issues

Post by Kurt » 19. June 2014 01:23

OK it looks I'm finally managed to reach my goal here. It was a lot of work but I've learned a lot new stuff.
Thanks to Kirk for pointing me in the right direction.
view my result on http://www.lambrettaforum.eu

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1432
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Install v2.0.2 issues

Post by Kirk » 19. June 2014 09:59

Looks good, have fun with the Portal. :)
Gruß Udo

Return to “Board3 Portal 2.0.x - English Support”