Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Aktuelle Version: 2.1.0
Veröffentlicht: 26.10.2015
Forum rules
Vor dem erstellen neuer Supportanfragen bitte zuerst in die board3 Portal FAQ schauen und die Suche benutzen!
Viele Fragen sind bereits schon gestellt und beantwortet worden.
Bitte auch unsere Forumsregeln lesen und beachten!
User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1410
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kirk » 20. January 2017 17:26

Ein Link zu deinem Board währe hiflreich.
Gruß Udo

Digidani
Active Member
Active Member
Posts: 12
Joined: 7. December 2014 12:33
phpBB.de User: Digidani
phpBB.com User: Schtorsch

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Digidani » 20. January 2017 17:35

http://www.dresdens-harter-kern.de :oops:

Da landet man auch direkt im Portal. Auch als Gast hat man Leserechte für diesen Foreneintrag - da sieht man die Unterschiede zwischen Forum und Portal ganz gut.

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1410
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kirk » 20. January 2017 20:20

Mach dochmal diese Änderung an der root/ext/board3/portal/portal/fetch_posts.php
Ob es daran liegt kann ich nich mit 100%er Sicherheit sagen.
Gruß Udo

Digidani
Active Member
Active Member
Posts: 12
Joined: 7. December 2014 12:33
phpBB.de User: Digidani
phpBB.com User: Schtorsch

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Digidani » 23. January 2017 09:32

Danke für den Tipp! :)

Aber es hat leider noch nicht geholfen. :oops:

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1410
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kirk » 24. January 2017 19:06

Ich kann bei mir dieses Verhalten nicht vollziehen.
Entweder du hast irgendwelche Änderungen am Style selbst vorgenommen oder es liegt an einer Erweiterung die du bei dir im Einsatz hast.
Gruß Udo

Digidani
Active Member
Active Member
Posts: 12
Joined: 7. December 2014 12:33
phpBB.de User: Digidani
phpBB.com User: Schtorsch

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Digidani » 27. January 2017 12:11

Okay, danke für die Prüfung und die Tipps. :)
Kann natürlich wirklich an einer Erweiterung liegen. Geändert habe ich selbst am Style nichts.

Da die Zeilenabstände dort aber nicht weiter so stören, lasse ich die Reecherche mal ruhen. Vielleicht ändert sich ja etwas bei einem der Addin-Updates oder aber beim kommenden Update vom Portal.

User avatar
cpg
Sponsor
Sponsor
Posts: 99
Joined: 3. September 2010 19:42
phpBB.de User: cpg
Location: Ringsberg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by cpg » 29. January 2017 11:42

Moin,

bei github wurden einige Style-Änderungen gepostet:

https://github.com/board3/Board3-Portal/commit/6cae1e4 (Style changes - pagination buttons)

Ich denke jedoch, die protal.css müsste auch noch angepasst werden; denn da steht (jedenfalls bei mir)
.portal-navigation ul li a{
background-image: url("./images/portal/arrowbullet.gif");
background-repeat: no-repeat;
Gruß
cpg

User avatar
Kevin
Site Admin
Site Admin
Posts: 2870
Joined: 7. January 2006 21:11
phpBB.de User: Saint
phpBB.com User: Saint_hh
Location: Hamburg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kevin » 29. January 2017 12:12

Moin cpg,

ja, ist korrekt. Bitte den commit ignorieren. Ich stolpere gerade (als Neuling) ziemlich durch GitHub und muss das erstmal gerade ziehen.
Leider weiß ich auch nicht wie ich den commit löschen kann.
Leider zeitlich recht eingeschränkt.

Gruß

Kevin
~~~ They say the definition of madness is doing the same thing and expecting a different result ~~~

Kein Support per PN / No support via PM!

User avatar
Kevin
Site Admin
Site Admin
Posts: 2870
Joined: 7. January 2006 21:11
phpBB.de User: Saint
phpBB.com User: Saint_hh
Location: Hamburg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kevin » 29. January 2017 14:05

So, ich hab mal korrigiert und fehlende Sachen übertragen.
Wahrscheinlich werde ich von Marc mit nassem Sellerie für meine Stümperei auf GitHub ausgepeitscht. ;)
~~~ They say the definition of madness is doing the same thing and expecting a different result ~~~

Kein Support per PN / No support via PM!

User avatar
MyLady
Sponsor
Sponsor
Posts: 105
Joined: 30. November 2009 17:11
phpBB.de User: MyLady
phpBB.com User: Scanialady

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by MyLady » 29. January 2017 14:19

Kevin wrote:
29. January 2017 12:12
Moin cpg,

ja, ist korrekt. Bitte den commit ignorieren. Ich stolpere gerade (als Neuling) ziemlich durch GitHub und muss das erstmal gerade ziehen.
Leider weiß ich auch nicht wie ich den commit löschen kann.
Leider zeitlich recht eingeschränkt.

Gruß

Kevin
Schön, dass es hier und dort doch noch weitergeht.
Aber heißt das, dass Marc die Entwicklung abgegeben hat? Nur mal so aus Neugier.
sorry for my bad english - I'm german and google is my friend :D
-----
Deutsche Übersetzungen, ggf. auch auf Anfrage
Arcade Adminwiki deutsch, im Aufbau.

User avatar
Kevin
Site Admin
Site Admin
Posts: 2870
Joined: 7. January 2006 21:11
phpBB.de User: Saint
phpBB.com User: Saint_hh
Location: Hamburg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kevin » 29. January 2017 14:37

MyLady wrote:
29. January 2017 14:19
Aber heißt das, dass Marc die Entwicklung abgegeben hat? Nur mal so aus Neugier.
Nein, das Portal, wie es heute ist, ist sein Baby und er hat wohl nicht vor das aufzugeben.
Ich würde mir auch nicht anmaßen ihn auch nur ansatzweise ersetzen zu können.
Da er als phpBB Hauptentwickler ordentlich eingespannt ist, habe ich mich angeboten das Forum hier mal von 3.0 auf 3.2 zu aktualisieren. So was kann ich ganz gut. 😉
Und darüber kamen dann die ersten Anpassungen am Portal, damit es unter phpBB 3.2 läuft und vernünftig aussieht. Kirk hat da den Großteil der Style Änderungen beigetragen.
Ansonsten scheinen sich die notwendigen Änderungen für phpBB 3.2 und PHP 7 in Grenzen zu halten. Es wird wohl in naher Zukunft eine erste Beta erscheinen.
~~~ They say the definition of madness is doing the same thing and expecting a different result ~~~

Kein Support per PN / No support via PM!

User avatar
cpg
Sponsor
Sponsor
Posts: 99
Joined: 3. September 2010 19:42
phpBB.de User: cpg
Location: Ringsberg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by cpg » 29. January 2017 15:45

Moin,

ich lasse erst einmal die bisherigen Grafiken so wie sie sind; ich finde sie ganz niedlich - und bei Font-Awsome gefällt mir längst nicht alles :)

Noch eine Frage zu den html-Dateien auf github. (Es soll keine Meckerei sein).
Muss ich meine Brille putzen, oder ist es so, dass einige Zeilen erst mit "-" entfernt werden und dann mit "+" wieder hinzugefügt werden?
Ich kann bei einigen Zeilen keinen Unterschied erkennen.

Gruß und schönen Sonntag
cpg

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1410
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by Kirk » 29. January 2017 17:22

cpg wrote:
29. January 2017 15:45
ist es so, dass einige Zeilen erst mit "-" entfernt werden und dann mit "+" wieder hinzugefügt werden?
Das ist korrekt, es gibt schon Unterschiede manche sind nicht gleich zu erkennen.
Gruß Udo

User avatar
cpg
Sponsor
Sponsor
Posts: 99
Joined: 3. September 2010 19:42
phpBB.de User: cpg
Location: Ringsberg

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by cpg » 2. February 2017 21:19

Moin,

es ist nur ein wenig OT :) aber ich möchte doch mal in die Runde fragen, ob es euch wichtig ist, dass der Code valide ist (W3C).
Ich habe etliche Stunde damit verbracht, angezeigte Fehler zu beseitigen.
Bei der Forumsoftware "ohne Portal" ist mir das ziemlich gelungen :) - "mit Portal" bleiben zwei Fehler übrig.
Allerdings ist die Funktionalität nicht eingeschränkt (war sie auch nicht mit mehr Fehlern).
Dummer Weise juckt es mich manchmal das "PASSED" zu lesen. Allerdings sind manche Fehlermeldungen (für mich) kaum nachzuvollziehen.

Gruß
cpg

EMW-327
Active Member
Active Member
Posts: 20
Joined: 3. August 2015 20:06

Re: Leider nicht mit phpbb 3.2 oder php 7.0 kompatibel?

Post by EMW-327 » 18. April 2017 09:10

Wird es in absehbarer Zeit eine Version des Boards geebn, die ohne große manuelle Änderungen für den Anwender zur Version PHPBB 3.2 passt?

Return to “Board3 Portal 2.1.x - Deutscher Support”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests