Portal issue

Current Version: 2.0.2
Released: 2013-10-27
Forum rules
Before creating a new support thread, please take a look at the board3 Portal FAQ and use the search!
Many questions have already been answered.

Topic author
Mordynak
Active Member
Active Member
Posts: 26
Joined: 6. April 2013 01:08

Portal issue

Post by Mordynak »

Your Portal Version: 2.0.1
Your phpBB Type: Standard phpBB3
MODs installed: No
Your knowledge: Basic Knowledge
Boardlink: http://provincecyrodiil.project-tamriel.com

What have you done before the problem was there?


What have you already tryed to solve the problem?


Description and Message
Having some minor issues after making some changes to my forum style. Basically I wanted to adjust the post profile area to be a fixed width.

I followed this quick guide. Which works fine as far as I can tell, everywhere except on the portal.

On the site http://provincecyrodiil.project-tamriel.com/ If you switch to the proCyrodiilWide style you will see the issue.

At first i thought it may be a problem with that style itself. So i tried it on my other forum http://highrock.project-tamriel.com/ and I get the same issue.

I'm sure it's something minor that's causing the issue but I just can't seem to see what it is.

Any help at all would be greatly appreciated. I know I'm using a slightly older version of the portal and I do intend to update it once ive gotten this issue resolved.

Thanks everyone, much appreciated!

Copyright has been re-added. I haven't worked on the site in a while. I was in the progress of moving the copyright, I have no intention of removing it. Apologies
User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1742
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal issue

Post by Kirk »

The problem is that here:

Code: Select all

.postbody {
    color: #0F1415;
    line-height: 1.48em;
    margin: 0 0 0 191px;
    padding: 0;
    width: auto;
}
Find and delete this :

Code: Select all

margin: 0 0 0 191px;

Topic author
Mordynak
Active Member
Active Member
Posts: 26
Joined: 6. April 2013 01:08

Re: Portal issue

Post by Mordynak »

Wow... That was quick.

Thanks a lot I really appreciate it!

On a slightly unrelated note. I have altered the board3 copyright, as in, I've moved it to the overall footer. Is that allowed?

Thanks again!

EDIT: Just curious. I don't suppose you know of a way to increase the padding on the left side of the post contents? The post content touches the vertical line next to the profile information?

Thanks again!!!
User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1742
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal issue

Post by Kirk »

Mordynak wrote:I have altered the board3 copyright, as in, I've moved it to the overall footer. Is that allowed?
Yes it is
Mordynak wrote:I don't suppose you know of a way to increase the padding on the left side of the post contents?
Copy this _block_config.html to root/styles/proCyrodiilWide/template/portal

Code: Select all

<!-- Config for the left and right blocks //-->
<!-- DEFINE $LR_BLOCK_H_L = '<div class="forabg"><div class="inner"><span class="corners-top"><span></span></span><ul class="topiclist"><li class="header"><li class="header"><dl class="icon"><dt style="width: auto;">' -->
<!-- DEFINE $LR_BLOCK_H_R = '</dt></dl></li></ul><ul class="topiclist forums"><li><dl><dd style="border-left: 0px; width: 100%;"><div style="text-align: left; margin: 5px 5px 5px 5px">' -->
<!-- DEFINE $LR_BLOCK_F_L = '</div></dd></dl></li></ul>' -->
<!-- DEFINE $LR_BLOCK_F_R = '<span class="corners-bottom"><span></span></span></div></div><br style="clear:both" />' -->

<!-- Config for the center blocks //-->
<!-- DEFINE $C_BLOCK_H_L = '<div class="forabg"><div class="inner"><span class="corners-top"><span></span></span><ul class="topiclist"><li class="header"><dl class="icon"><dt>' -->
<!-- DEFINE $C_BLOCK_H_R = '</dt></dl></li></ul>' -->
<!-- DEFINE $C_BLOCK_F_L = '' -->
<!-- DEFINE $C_BLOCK_F_R = '<span class="corners-bottom"><span></span></span></div></div><br style="clear:both" />' -->

<!-- Config for compact blocks //-->
<!-- DEFINE $CC_BLOCK_H_L = '<div class="forabg"><div class="inner"><span class="corners-top"><span></span></span><ul class="topiclist"><li class="header"><dl class="icon">' -->
<!-- DEFINE $CC_BLOCK_H_R = '</dl></li></ul>' -->

<!-- Images-URL //-->
<!-- DEFINE $NO_AVATAR_IMG = '/images/no_avatar.gif' -->

<!-- Vertical distance between left/right and center Blocks -->

<!-- DEFINE $BLOCK_DISTANCE = '10px' -->

<!-- show Icons in left/right Blocks? 0=no 1=yes -->
<!-- DEFINE $S_BLOCK_ICON = 1 -->

<!-- postbody top (default 1 by prosilver) 0=no 1=yes -->
<!-- DEFINE $S_POSTBODY_TOP = 1 -->

<!-- override the column width settings of the ACP for this style? 0=no 1=yes -->
<!-- DEFINE $S_COLUMNS_WIDTH_OVERRIDE = 0 -->

<!-- override the column width settings of the ACP - set the width if enabled -->
<!-- DEFINE $PORTAL_LEFT_COLUMN_OVERRIDE = '200' -->
<!-- DEFINE $PORTAL_RIGHT_COLUMN_OVERRIDE = '200' -->
So it looks after:
pro_cyrodiil_wide.jpg
You do not have the required permissions to view the files attached to this post.

Topic author
Mordynak
Active Member
Active Member
Posts: 26
Joined: 6. April 2013 01:08

Re: Portal issue

Post by Mordynak »

Apologies for the delay. Adding the block config to the template did fix an issue I had with styling on the portal which is excellent!

However I still have one minor issue left. After making the profile pane a fixed size, the post contents are pushed right up to the edge of the profile information.

The best example I can give is if you view this topic
http://provincecyrodiil.project-tamriel ... f=4&t=1158

Compare the proCyrodiil style to the Wide style and you will see that the contents are pushed to the left, most noticeable is the attachments box.

Apologies if this is a phpbb problem and not a Board3 issue.

Thanks again for the help, It really is much appreciated!
User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1742
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal issue

Post by Kirk »

This is a style issue and has nothing to do with the portal.
Turn you at phpbb.com

Return to “Board3 Portal 2.0.x - English Support”